読者です 読者をやめる 読者になる 読者になる

のぶLab.

流しのソフトウェアエンジニアの雑記帳. Android, Scala, Clojure, Ruby on Railsなど

Android + Kotlinなプロジェクトでjava.lang.NoSuchMethodError

com.android.tools.build:gradle:2.2.0-alpha1とKotlinを使用する場合、dependenciesの記述順によってはerrorになるみたいです。

stackoverflow.com

NG

dependencies {
    classpath 'com.android.tools.build:gradle:2.2.0-alpha1'
    classpath 'org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version'
}

OK

dependencies {
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
    classpath 'com.android.tools.build:gradle:2.2.0-alpha1'
}